Устанавливаем Aperture 2.0 на неподдерживаемые компьютеры

Если у вас старенький Мак, но вы хотите установить на него Aperture 2.0, то, вероятно, вы получите сообщение о том, что ваш компьютер не поддерживается и не сможете установить программу. Однако, для того, чтобы всё-таки установить её, вы можете сделать следующее:

  • Вставьте DVD-диск с Aperture
  • Откройте терминал
  • Введите там следующие команды:
    $ mkdir -p /tmp/aperture
    $ cp -r /Volumes/Aperture/{Aperture.mpkg,Packages} /tmp/aperture/
    $ open /tmp/aperture
    
  • В открывшемся окне найдите файл ApertureTrial.mpkg
  • Щёлкните по нему правой кнопкой мыши, выберите Show Package Contents и откройте папку Contents
  • Найдите там файл Aperture.dist и отркройте его в любом текстовом редакторе
  • Найдите такую строку:
    <installation -check script='installationCheck()'/>
    
    и замените её на следующую:
    <!--<installation-check script='installationCheck()'/>-->
    
  • Сохраните файл
  • Вернитесь обратно в /tmp/aperture и запустите Aperture.mpkg
  • Установите Aperture 2.0

После установки вы можете удалить установочные файлы из /tmp/aperture.

  • Сергей

    Ага, у меня на новейший Макбук про не установилась…

    • http://karguine.blogspot.com bm

      Ну это явно не от того, что он не поддерживается. Обратитесь в техподдержку Apple.